1

How to align calendars times and timeslot lines?

asked 2014-04-07 08:04:45 +0800

SKzEdd gravatar image SKzEdd
12 3

updated 2014-04-07 08:18:32 +0800

In the zk calendars live demo mold="default" and days="1" the time slot lines do not match the the times. How do I fix this? This can be seen the best on 23:00 since there are no time slot lines.

delete flag offensive retag edit

Comments

@RaymondChao: Hello and thank you very much! Works perfectly.

SKzEdd ( 2014-04-09 07:49:11 +0800 )edit

2 Answers

Sort by ยป oldest newest most voted
1

answered 2014-04-09 05:31:26 +0800

RaymondChao gravatar image RaymondChao
386 1 4

Hello

The situation only happens in ZK7, its alignment is correct in ZK6, I've create the issue.

The workaround of fixing the alignment when using ZK7 is to add the following style:

.z-calendars-hour-sep {
    height: 24px;
}

Help this could help.

link publish delete flag offensive edit
0

answered 2014-05-28 16:32:10 +0800

Matt81 gravatar image Matt81
1

Hello guys,

I had the same problem, and the latest version of calendar library fixes it.

But I've noticed that, if I increase the number of time slots (in the default mold), the problem rises again: times and time slots lines are not aligned.

What do you think about it? Maybe the issue should be reopened?

Thank you for help.

link publish delete flag offensive edit

Comments

Bug fixed with new version (update 2014/5/29)

Matt81 ( 2014-05-29 12:41:40 +0800 )edit
Your answer
Please start posting your answer anonymously - your answer will be saved within the current session and published after you log in or create a new account. Please try to give a substantial answer, for discussions, please use comments and please do remember to vote (after you log in)!

[hide preview]

Question tools

Follow
2 followers

RSS

Stats

Asked: 2014-04-07 08:04:45 +0800

Seen: 22 times

Last updated: May 28 '14

Support Options
  • Email Support
  • Training
  • Consulting
  • Outsourcing
Learn More