0

listheader menupopup="auto" not working?

asked 2014-02-11 22:59:33 +0800

rwoolf gravatar image rwoolf
35 5

I have tried adding menupopup="auto" to my listheader items, but I get the exception: org.zkoss.zk.ui.metainfo.PropertyNotFoundException: Method setMenupopup not found for class org.zkoss.zul.Listheader when the zul tries to load.

<listheader label="Tracking #" menupopup="auto"/>

The documentation for listheader says it should work since 6.5. I am on 6.5.4. http://books.zkoss.org/wiki/ZKComponentReference/Data/Listbox/Listheader (see bottom of page)

It works if I add it to column elements in a grid, but it fails when using it on a listheader in a listbox.

Am I doing something wrong? Is there a bug?

delete flag offensive retag edit

Comments

Just try it <listhead menupopup="auto">

sitansu ( 2014-02-12 17:02:47 +0800 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2014-02-12 03:17:52 +0800

RaymondChao gravatar image RaymondChao
386 1 4

updated 2014-02-12 03:21:08 +0800

Hello rwoolf,

The property can be assigned in Listhead, not Listheader. As the below shows:

<listhead menupopup="auto">
  <listheader label="Tracking A"/>
  <listheader label="Tracking B"/>
  <listheader label="Tracking C"/>
</listhead>

Please refer Listhead for more details.

menupopup="auto" works the same as grid in the demo.

link publish delete flag offensive edit

Comments

Thanks for the clarification

rwoolf ( 2014-02-12 18:03:27 +0800 )edit
Your answer
Please start posting your answer anonymously - your answer will be saved within the current session and published after you log in or create a new account. Please try to give a substantial answer, for discussions, please use comments and please do remember to vote (after you log in)!

[hide preview]

Question tools

Follow
1 follower

RSS

Stats

Asked: 2014-02-11 22:59:33 +0800

Seen: 35 times

Last updated: Feb 12 '14

Support Options
  • Email Support
  • Training
  • Consulting
  • Outsourcing
Learn More