1

Filter fileupload with parameter accept

asked 2014-01-22 12:15:45 +0800

sarco gravatar image sarco flag of Spain
93 6
https://github.com/sarcow...

I'm trying to make a filter for fileupload with: ZK Component Reference/Button

I have tried with: upload="true,maxsize=-1,multiple=true,accept=image/*|MIME_type"/>

But doesn't work...so it accepts all files types.

Thank you.

delete flag offensive retag edit

1 Answer

Sort by ยป oldest newest most voted
3

answered 2014-01-22 12:34:47 +0800

chillworld gravatar image chillworld flag of Belgium
5322 4 9
https://github.com/chillw...

Oke there are 2 things very important for that(and remove the |MIME_Type so you have only images) :

accept: specifies the types of files that the server accepts, the setting only works with HTML5 supported browsers (since ZK 7.0.0)

Do you use ZK 7.0.0 Have you tested with browser that supports HTML5?

Greetz chill.

link publish delete flag offensive edit

Comments

That was the problem, removing "|MIME_Type". Thank you very much!

sarco ( 2014-01-22 12:45:35 +0800 )edit

your welcome

chillworld ( 2014-01-22 13:06:32 +0800 )edit
Your answer
Please start posting your answer anonymously - your answer will be saved within the current session and published after you log in or create a new account. Please try to give a substantial answer, for discussions, please use comments and please do remember to vote (after you log in)!

[hide preview]

Question tools

Follow
1 follower

RSS

Stats

Asked: 2014-01-22 12:15:45 +0800

Seen: 41 times

Last updated: Jan 22 '14

Support Options
  • Email Support
  • Training
  • Consulting
  • Outsourcing
Learn More