1

Themes - changes not showing

asked 2013-12-02 19:27:38 +0800

ansancle gravatar image ansancle
317 9

updated 2013-12-02 19:29:11 +0800

I am using ZK 7.0 EE I have used the ztx.bat tool and created my own folder based theme. It is being correctly registered and shows as the current theme after I register and set it. The cookie exists for theme and is properly set to mydefaulttheme. This is the code I use to register and set my theme :

            Themes.register("mydefaulttheme", ThemeOrigin.FOLDER);
            Themes.register("tablet:mydefaulttheme", ThemeOrigin.FOLDER);   
            Themes.setTheme(Executions.getCurrent(), "mydefaulttheme");

Here is the directory structure under application root which is as it should be:

WebRoot
-theme
    - mydefaulttheme
       - js
       - zkex
       - zkmax
       - zul

The problem I am having is when I make changes to the .css.dsp files, those changes are not being reflected when I run. I have made some dramatic changes just to test and see if they would show up and they don't.

Any ideas?

Thanks! Andy

delete flag offensive retag edit

Comments

Hi Anacle, I can't reproduce this issue. Can you tell me more details like what server and what browser/version you observe this issue with?

ashishd ( 2013-12-03 10:29:09 +0800 )edit

We are running via Jboss 7 and I have tried checking my site via firefox on ubuntu and our Ipad App (basically safari). I will try running some more tests, is there any special way I should edit the css.dsp files? I was making changes like I would in any css.

ansancle ( 2013-12-03 11:25:37 +0800 )edit

When I open the developer tools from FirefoX and look at the html, this is in the body definition : <body class="gecko gecko23 mydefaulttheme" > so it really looks like it's using the theme, but ever change I make under the theme is ignored.

ansancle ( 2013-12-03 17:56:44 +0800 )edit

What sort of changes are you making to theme files? Can you give me an example so I can try similar sample.

ashishd ( 2013-12-16 08:11:14 +0800 )edit

I made the following changes in grid.css.dsp for example and none of them showed up. I had to put the same changes into an included .css file to get my results. See response, thought I could post code in the comment but can't. The changes basically eliminate any grid border or background coloring.

ansancle ( 2013-12-16 13:43:14 +0800 )edit

3 Answers

Sort by ยป oldest newest most voted
1

answered 2014-05-22 01:10:47 +0800

mjmckay gravatar image mjmckay
10 1

Found a solution and posted answer on post "Problem when adding images and cssdsp files to a customized theme".

link publish delete flag offensive edit
0

answered 2013-12-16 13:44:08 +0800

ansancle gravatar image ansancle
317 9
    tr.z-row-over .td.z-row-inner .z-row-content{
    border-bottom: 1px solid white;
    border-top: 1px solid white;
     background-image: none;
}
tr.z-row-over  .td.z-row-inner, tr.z-row-over > .z-cell {
    background-image: none;
}

.z-row:hover
{
     background-image: none;    
     color : white !important;
}

.z-row:hover > .z-row-inner, .z-row:hover > z.cell
{
    background: none !important;
    position:relative;
}


.z-row-over .td.z-row-inner .z-row-content{
    border-bottom: 1px solid white;
    border-top: 1px solid white;
     background-image: none;
}
.z-row-over  .td.z-row-inner, tr.z-row-over > .z-cell {
    background-image: none;
}

.z-row:hover
{
     background-image: none;    
     color : white !important;
}

.z-row:hover > .z-row-inner, .z-row:hover > z.cell
{
    background: none !important;
    position:relative;
}


.z-row .z-row-inner,.z-row .z-cell
{
    background:white;
    border-top:none;
    border-left:1px solid white;
    border-right:1px solid #FFFFFF;
    border-bottom:1px solid #FFFFFF;
}

.z-grid-odd .z-cell {
    background-color: #FFFFFF;
    border-bottom: 1px solid #FFFFFF;
    border-left: 1px solid #FFFFFF;
    border-top: 1px solid #FFFFFF;
}

.z-grid 
{    
    border: 0 solid #FFFFFF;
    overflow: hidden;
}
link publish delete flag offensive edit
0

answered 2014-05-20 20:59:59 +0800

mjmckay gravatar image mjmckay
10 1

Hi Andy,

Did you ever solve this? I'm having the same issue.

Mike

link publish delete flag offensive edit
Your answer
Please start posting your answer anonymously - your answer will be saved within the current session and published after you log in or create a new account. Please try to give a substantial answer, for discussions, please use comments and please do remember to vote (after you log in)!

[hide preview]

Question tools

Follow
1 follower

RSS

Stats

Asked: 2013-12-02 19:27:38 +0800

Seen: 41 times

Last updated: May 22 '14

Support Options
  • Email Support
  • Training
  • Consulting
  • Outsourcing
Learn More