0

desktop timeout

asked 2013-04-26 11:59:06 +0800

davidtrabajo gravatar image davidtrabajo
6

hi,

I´ve got this configuration. ZK 6.5.0

<desktop-config>
    <desktop-timeout>60</desktop-timeout>
    <automatic-timeout>true</automatic-timeout>
</desktop-config>

<session-config>
    <session-timeout>120</session-timeout>
    <automatic-timeout>true</automatic-timeout>
    <timer-keep-alive>false</timer-keep-alive>
    <max-desktops-per-session>15</max-desktops-per-session>
    <max-requests-per-session>5</max-requests-per-session>
    <max-pushes-per-session>-1</max-pushes-per-session>
</session-config>

<listener>
    <listener-class>es.aeat.comun.zk.timeouts.DesktopListener</listener-class>
</listener>
<listener>
    <listener-class>es.aeat.comun.zk.timeouts.SessionListener</listener-class>
</listener>

The session-timeout is working fine, but the desktop-timeout is not working, DesktopListener won´t be called until 120+ seconds have passed wich is the session-timeout.

Does someone know if i´m doing anything wrong?

Thanks in advance.

delete flag offensive retag edit
Be the first one to answer this question!
Please start posting your answer anonymously - your answer will be saved within the current session and published after you log in or create a new account. Please try to give a substantial answer, for discussions, please use comments and please do remember to vote (after you log in)!

[hide preview]

Question tools

Follow
1 follower

RSS

Stats

Asked: 2013-04-26 11:59:06 +0800

Seen: 34 times

Last updated: Apr 26 '13

Support Options
  • Email Support
  • Training
  • Consulting
  • Outsourcing
Learn More