HTTP 501 - Service unimplemented

asked 2013-04-23 08:25:13 +0800

imohite gravatar image imohite

I'm using ZK 5.0.3 Framework + IE 9 + Weblogic 10.3. On my UI, I get HTTP 501 service unimplemented error randomly. I've verified the code and nothing suspicious found. When I intercepted the HTTP messages between IE and Weblogic using Fiddler, found that there were garbage characters prepended to the POST method. Here's a sample intercepted RAW HTTP message sent by UI to backend.

ERROR : 22%3A0%2C%22LEFT%22%3A160%7D&CMD2=ONSCROLLPOS&UUID2=UQ0Q2R&DATA2=%7B%22TOP%22%3A0%2C%22LEFT%22%3A2948%7D&CMD3=ONCLICK&UUID3=UQ0Q1R&DATA3=%7B%22PAGEX%22%3A360%2C%22PAGEY%22%3A225%2C%22WHICH%22%3A1%2C%22X%22%3A5%2C%22Y%22%3A-3%7DPOST httpurl:// HTTP/1.1 Accept: / Content-Type: application/x-www-form-urlencoded;charset=UTF-8 ZK-SID: 2331 Referer: httpurl:// Accept-Language: en-in Accept-Encoding: gzip, deflate User-Agent: Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.1; WOW64; Trident/5.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; .NET4.0C; .NET4.0E; BRI/2) Host: Content-Length: 136 Connection: Keep-Alive Pragma: no-cache Cookie: JSESSIONID=D9TTRnFR8DyWpGc84cQZxVW1Gx7K0Z14kKRKsDQmntr9zSkZtYk8!-1480174431


Interestingly, the ZK library has a retry mechanism which retries the HTTP communication if there's a 5xx error code. However, when it retries for the second time, it does send the correct HTTP method, no garbage characters prepended. Does anyone know how to solve this?

delete flag offensive retag edit


Hi, I have tried ZK 5.0.3 & ZK 6.5.2 + IE 9

samchuang ( 2013-04-29 05:30:55 +0800 )edit

2 Answers

Sort by » oldest newest most voted

answered 2013-04-29 05:48:02 +0800

samchuang gravatar image samchuang
4084 4

Hi, I have tried ZK 5.0.3 (zk-demo-5.0.3.zip)& ZK 6.5.2 (zk-sandbox-6.5.2.zip)+ IE 9 + Weblogic 10.3 with Window 7, using zksandbox War demo application, the application works fine, I didn't get 501 response, can you provide a War file that can reproduce the issue?

link publish delete flag offensive edit

answered 2013-04-29 06:37:29 +0800

imohite gravatar image imohite

Hey samchuang, I really appreciate the efforts taken by you. Yesterday, we did narrow down the problem and found out the actual cause. We were using IE Version: 9.0.8112.16421 - Update Versions: 9.0.6 (KB2675157) which was producing this defect. We tried on another Windows machine with IE Version: 9.0.8112.16421 - Update Versions: 9.0.15 (KB2817183) and it ran smoothly. It was clear that the 9.0.6 had some problem and so we upgraded it with "Automatic Updates On". As it got upgraded to 9.0.15 (KB2817183), the problem disappeared.

link publish delete flag offensive edit
Your answer
Please start posting your answer anonymously - your answer will be saved within the current session and published after you log in or create a new account. Please try to give a substantial answer, for discussions, please use comments and please do remember to vote (after you log in)!

[hide preview]

Question tools

1 follower



Asked: 2013-04-23 08:25:13 +0800

Seen: 8 times

Last updated: Apr 29 '13

Support Options
  • Email Support
  • Training
  • Consulting
  • Outsourcing
Learn More