6

The New ZK Essentials now available online!

asked 2013-03-29 08:16:34 +0800

southerncrossie gravatar image southerncrossie
1739 1 14

updated 2013-04-01 02:57:27 +0800

jimyeh gravatar image jimyeh
2047 1 4
ZK Team

The new ZK Essentials is divided into 10 chapters to walk you through key concepts & features of ZK step by step by building a working application from scratch.

Get started Now!!!

http://books.zkoss.org/wiki/ZK_Essentials

delete flag offensive retag edit

14 Replies

Sort by ยป oldest newest

answered 2013-03-29 10:39:58 +0800

Steva77 gravatar image Steva77 flag of Italy
1014 3
http://www.research.softe...

Nice indeed!

Any chance to have the (lovely old) pdf format for offline training?!

link publish delete flag offensive edit

answered 2013-03-30 08:42:56 +0800

azli gravatar image azli
24 3

This new guide is superb! Completes with examples foreach chapter. Great job. This essentials can assume as skeleton project. Just add few more integration like spring security,workflow, maybe spreadsheet and calendar also.

Any plan for spring security? User roles management? Thanks for this

link publish delete flag offensive edit

answered 2013-03-30 23:06:26 +0800

franferri gravatar image franferri
48 2

Amazing material.

link publish delete flag offensive edit

answered 2013-03-31 13:09:41 +0800

azli gravatar image azli
24 3

i just downloaded the examples. essentials_master and chapter 9 works fine. but can not run example 10. anybody else having this problem?

link publish delete flag offensive edit

answered 2013-04-01 03:49:48 +0800

hawk gravatar image hawk
2255 1 5
http://hawkphoenix.blogsp... ZK Team

@azli

What problem do you encounter? could you give us your error message?

link publish delete flag offensive edit

answered 2013-04-01 10:57:10 +0800

azli gravatar image azli
24 3

updated 2013-04-01 11:02:46 +0800

hi hawk, i tried mvn jetty:run on the chapter. this is the console output

edit: sorry for unreadable code. here i put in pastebin pastebin(dot)com/svUePzJN

thank you for any help

link publish delete flag offensive edit

answered 2013-04-02 02:38:53 +0800

hawk gravatar image hawk
2255 1 5
http://hawkphoenix.blogsp... ZK Team

updated 2013-04-02 02:42:11 +0800

hi @azil

it's maven-compiler-plugin configuration error. (<source> & <target> should be 1.6) Please download from repository again, it has been fixed.

I also notice your error message contains

java.net.BindException: Address already in use: bind

it means you start two servers listening at the same port, the server fails to service.

link publish delete flag offensive edit

answered 2013-04-02 05:25:42 +0800

azli gravatar image azli
24 3

@Hawk,

Thanks for the help. I have downloaded the the latest from repository again. Checked the pom.xml and yes maven-compiler-plugin has changed to 1.6

however, another error has occurs. i think it has something to do with persistence. here, the error : pastebin(dot)com/UpsNsgCw

check out error at line 85 and info at line 75.

p/s : yes, yesterday i did tried to run this app with my tomcat running. sorry for that.

link publish delete flag offensive edit

answered 2013-04-02 08:52:12 +0800

hawk gravatar image hawk
2255 1 5
http://hawkphoenix.blogsp... ZK Team

@azil

Thanks for your report. The issue is fixed. please download it again.

link publish delete flag offensive edit

answered 2013-04-02 13:29:04 +0800

azli gravatar image azli
24 3

@Hawk

Downloaded and tested. its now working. Thank you so much

link publish delete flag offensive edit
Your reply
Please start posting your answer anonymously - your answer will be saved within the current session and published after you log in or create a new account. Please try to give a substantial answer, for discussions, please use comments and please do remember to vote (after you log in)!

[hide preview]

Question tools

Follow
3 followers

RSS

Stats

Asked: 2013-03-29 08:16:34 +0800

Seen: 156 times

Last updated: May 27 '16

Support Options
  • Email Support
  • Training
  • Consulting
  • Outsourcing
Learn More