1

Missing Buttons on iPad [closed]

asked 2013-02-04 03:23:56 +0800

rdgrimes gravatar image rdgrimes
735 7

Should I report this as a bug? This app (see pic below) has the buttons missing when run on iPad. When run on desktop browser, the buttons show up fine. Note missing combobox button and grid paging buttons.

Has anyone else see the same type of behavior?

image description

delete flag offensive retag edit

The question has been closed for the following reason "the question is answered, right answer was accepted" by rdgrimes
close date 2013-02-05 17:04:46

Comments

hi, rdgrimes, what version of zk do u have?

noahhuang ( 2013-02-04 04:09:01 +0800 )edit

I am running 6.5.1.1 of ZK and the device is the iPad 4.

rdgrimes ( 2013-02-04 16:06:16 +0800 )edit

1 Answer

Sort by » oldest newest most voted
2

answered 2013-02-05 16:59:00 +0800

rdgrimes gravatar image rdgrimes
735 7

updated 2013-02-05 17:00:58 +0800

Here's what causes the invisible button problem.

Add the following meta tag to the top of your ZUL:

<?meta name="apple-mobile-web-app-capable" content="yes"?>

Bring up your test page in Safari on the iPad, and bookmark that page to your home screen. Then, open the page through your home screen. (I had done this because it is the only way to get a page to maximize on the iPad.)

If you have the given meta tag in your ZUL and then open it from the home screen, you’ll see that no buttons appear. But, if you leave that meta tag off, it shows the buttons in the app.

link publish delete flag offensive edit

Question tools

Follow
2 followers

RSS

Stats

Asked: 2013-02-04 03:23:56 +0800

Seen: 37 times

Last updated: Feb 05 '13

Support Options
  • Email Support
  • Training
  • Consulting
  • Outsourcing
Learn More