0

Problem migrating from 5.0.10 to 6.0.0 [closed]

asked 2012-02-24 10:18:16 +0800

gganassin gravatar image gganassin flag of Luxembourg
540 6
http://www.hybris.com/

Hi all!

I'm currently upgrading our applications from the 5.0.10 to the 6.0.0 and i'm having a strange issue.

We have many forms with a custom validation mechanism that is triggered once the user tries to save the object and if some constraints (our custom ones not the ZK native constraint) over the fields are not satisfied, those fields are marked in red and a nice popup is launched to list to the user the current problems and the operation is aborted.

Everything is working fine apparently as before (the save is interrupted, the fields are marked in red and the popup is shown) but the default ZK red central popup appears with the following messages:

Failed to process script Object function (bX,bY){return new bC.fn.init(bX,bY,bA)} has no method 'addClass' (TypeError)

ON the Console:

Feb 24, 2012 11:09:38 AM org.zkoss.zk.ui.impl.DesktopImpl service:714
SEVERE: [Desktop z_ybj:/index.zul] client error: Failed to process 
script
Object function (bX,bY){return new bC.fn.init(bX,bY,bA)} has no method 'addClass' (TypeError)

One for each field that failed our validation.

Guess something went wrong client side right? Any ideas?

Thanks in advance!
Giovanni

delete flag offensive retag edit

The question has been closed for the following reason "question is not relevant or outdated" by gganassin
close date 2013-05-10 14:12:23

5 Replies

Sort by ยป oldest newest

answered 2012-02-27 10:54:06 +0800

gganassin gravatar image gganassin flag of Luxembourg
540 6
http://www.hybris.com/

Thread closed:
Found the following line of code who was a typo or just an attempt who was not causing problems with the 5.*.

jQuery.addClass("popupBox"); 

Thanks anyway!

link publish delete flag offensive edit

answered 2012-02-27 10:04:30 +0800

gganassin gravatar image gganassin flag of Luxembourg
540 6
http://www.hybris.com/

updated 2012-02-27 10:06:19 +0800

by "zk default popup" i mean this:

The second popup on the bottom is ofc mine... the field is red... so apparently everything is working fine... but the red one comes anyway.

Atm i'm try to isolate the problem in a simple demo app that uses my validation tools... hope to get rid of it but this javascript exception is really strange -.-

link publish delete flag offensive edit

answered 2012-02-25 08:00:09 +0800

benbai gravatar image benbai
2228 6
http://www.zkoss.org

As mentioned above the constraints are custom in stead of zk native,
if they are at server side you may try throw some custom exception and set the error page to process them.

Please refer to ZK Configuration Reference/zk.xml/The error-page Element

Regards,
ben

link publish delete flag offensive edit

answered 2012-02-24 11:06:13 +0800

gganassin gravatar image gganassin flag of Luxembourg
540 6
http://www.hybris.com/

Will try to reproduce outside the application Ben... which is quite a challenge but ill try!

Is there any way to configure the app in order to NOT show the zk default popup no matter what it happens? At least i can hide the problem for the moment

Giovanni

link publish delete flag offensive edit

answered 2012-02-24 10:48:52 +0800

benbai gravatar image benbai
2228 6
http://www.zkoss.org

Hi Giovanni,

Could you provide a simple sample that can reproduce this problem?
Thanks.

ben

link publish delete flag offensive edit

Question tools

Follow

RSS

Stats

Asked: 2012-02-24 10:18:16 +0800

Seen: 194 times

Last updated: Feb 27 '12

Support Options
  • Email Support
  • Training
  • Consulting
  • Outsourcing
Learn More