0

Mouse event error

asked 2010-05-03 07:07:04 +0800

dastultz gravatar image dastultz
797 8

Hello, I'm wondering if anyone can give me some idea of what might be causing this. It's happened a couple of times but not repeatable.

For input string: "NaN"
java.lang.NumberFormatException: For input string: "NaN"
       at java.lang.NumberFormatException.forInputString(NumberFormatException.java:48)
       at java.lang.Integer.parseInt(Integer.java:449)
       at java.lang.Integer.parseInt(Integer.java:499)
       at org.zkoss.zk.au.in.MouseCommand.process(MouseCommand.java:53)
       at org.zkoss.zk.au.Command.process(Command.java:131)
       at org.zkoss.zk.ui.impl.UiEngineImpl.process(UiEngineImpl.java:1237)
       at org.zkoss.zk.ui.impl.UiEngineImpl.execUpdate(UiEngineImpl.java:1013)
       at org.zkoss.zk.au.http.DHtmlUpdateServlet.process(DHtmlUpdateServlet.java:497)
       at org.zkoss.zk.au.http.DHtmlUpdateServlet.doGet(DHtmlUpdateServlet.java:382)
       at org.zkoss.zk.au.http.DHtmlUpdateServlet.doPost(DHtmlUpdateServlet.java:391)

/Daryl

delete flag offensive retag edit

6 Replies

Sort by ยป oldest newest

answered 2010-05-03 19:50:05 +0800

PeterKuo gravatar image PeterKuo
481 2

Which version of ZK are you using?
If you have update to latest version, (like 3.6.x)
and not use any customized component.
Then, it should be a bug of zk.

It look like the command data has some inconsistent,
expected int, like position x, position y. But found the value is not a number.

It's better to have reproducible scenario to fix it.

link publish delete flag offensive edit

answered 2010-05-04 07:16:20 +0800

dastultz gravatar image dastultz
797 8

I believe it's 3.6.3FL. I've never seen it happen to me, only twice on the production system. I've just done some snooping and I have determined that the users were using Blackberry's:

User Agents:
BlackBerry9630/4.7.1.61 Profile/MIDP-2.0 Configuration/CLDC-1.1 VendorID/105
BlackBerry9630/4.7.1.53 Profile/MIDP-2.0 Configuration/CLDC-1.1 VendorID/189

/Daryl

link publish delete flag offensive edit

answered 2010-05-04 21:12:27 +0800

PeterKuo gravatar image PeterKuo
481 2

Please report to bug.
But, it would be better to have reproducible scenario.
Do blackberry use its proprietary browser? Or user use some particular browser?

link publish delete flag offensive edit

answered 2010-05-05 07:52:50 +0800

dastultz gravatar image dastultz
797 8

>Please report to bug.
https://sourceforge.net/tracker/?func=detail&aid=2997111&group_id=152762&atid=785191

> But, it would be better to have reproducible scenario.
Naturally, but I don't have a BlackBerry!

>Do blackberry use its proprietary browser? Or user use some particular browser?
I don't know much of anything about it.

/Daryl

link publish delete flag offensive edit

answered 2010-05-06 07:29:39 +0800

dastultz gravatar image dastultz
797 8

Tom,

You've marked this bug as closed with the comment "Fixed since 5/6" but the bug resolution is "none". Is it fixed? If so, for what Zk version(s)?

/Daryl

link publish delete flag offensive edit

answered 2010-05-09 21:18:31 +0800

tomyeh gravatar image tomyeh
610 1 3
http://blog.zkoss.org ZK Team

Yes, you can check out the source codes from the svn repository, or wait for our next freshly release for 3.6.5 (or you can try 5.0.2 freshly).

link publish delete flag offensive edit
Your reply
Please start posting your answer anonymously - your answer will be saved within the current session and published after you log in or create a new account. Please try to give a substantial answer, for discussions, please use comments and please do remember to vote (after you log in)!

[hide preview]

Question tools

Follow

RSS

Stats

Asked: 2010-05-03 07:07:04 +0800

Seen: 318 times

Last updated: May 09 '10

Support Options
  • Email Support
  • Training
  • Consulting
  • Outsourcing
Learn More