Build problem

asked 2009-09-09 09:36:51 +0800

zknewbie gravatar image zknewbie
108 2

I will repost a message that I have posted one hour ago, but seems to be gone (this is the second time this happens, probably due to a bug in the forum software):


I have tried to run a build on the ZK sources, but i ran into trouble. It seems that there are some problems with line separators (CR/LF), but I have no clue in which file. I am using Cygwin on Windows XP. The archive was unpacked using WinRar.

The error I get is the following:

me@localhost /cygdrive/c/work/build/zk-src-3.6.2
$ ./build
dflag=on, oflag=on
targets: zcommon zweb zk zul zkex zhtml zml zkmax zkplus zkdemo deploy
build.debug zcommon ...
/cygdrive/v/utils/ant/bin/ant: line 2: $'\r': command not found
/cygdrive/v/utils/ant/bin/ant: line 17: $'\r': command not found
/cygdrive/v/utils/ant/bin/ant: line 20: $'\r': command not found
/cygdrive/v/utils/ant/bin/ant: line 22: $'\r': command not found
/cygdrive/v/utils/ant/bin/ant: line 23: syntax error near unexpected token `$'in
'cygdrive/v/utils/ant/bin/ant: line 23: `case "`uname`" in

Can anyone help?

Thanks in advance!


delete flag offensive retag edit

1 Reply

Sort by ยป oldest newest

answered 2009-09-09 10:52:51 +0800

zknewbie gravatar image zknewbie
108 2

Problem solved. I have remounted all the cygwin drives in text mode.


link publish delete flag offensive edit
Your reply
Please start posting your answer anonymously - your answer will be saved within the current session and published after you log in or create a new account. Please try to give a substantial answer, for discussions, please use comments and please do remember to vote (after you log in)!

[hide preview]

Question tools




Asked: 2009-09-09 09:36:51 +0800

Seen: 1,069 times

Last updated: Sep 09 '09

Support Options
  • Email Support
  • Training
  • Consulting
  • Outsourcing
Learn More