0

Hanging on "Processing"

asked 2009-04-21 19:27:48 +0800

dastultz gravatar image dastultz
797 8

I have a moderately complex app running in Zk 3.5.2. The users complain about the app occasionally getting "stuck". A click on a component that is supposed to replace a custom calendar with a day view simply results in the "Processing" box displaying and no other response. I don't think the page is especially large in terms of components. At least one user claimed to have to reboot the computer to get out of it. I suspect this user was not especially technically savy, so I don't know how much that is worth.

I can't reproduce the problem. I'm looking for some general ideas to troubleshoot this. What happens on the client side when the server fails to respond in a timely manner or doesn't respond at all? Suppose the server returns a 503 error or something?

I'm sure the users are using IE on Windows. Are there any patterns to IE hanging on "Processing"? Is there anything purely client-side that could be causing this?

Thanks.
/Daryl

delete flag offensive retag edit

9 Replies

Sort by ยป oldest newest

answered 2009-04-22 12:11:05 +0800

dastultz gravatar image dastultz
797 8

I'm bumping this thread because it seems to have disappeared from the listing.

link publish delete flag offensive edit

answered 2009-04-22 14:01:27 +0800

msrednsi gravatar image msrednsi
106 2

Hello, i'm experiencing this problem: also zk 3.5.2, Safari 3.2.1. Mac OS X. Using FF 3.1b3 it runs fine.

It showed up after adding to the app an autorefresh capability using server push and i began using the tablelayout/columnlayout component.

My app use a single desktop interface, where dynamically created windows are used to access application objects and processes. The point is that simple windows load ok but some complex ones, always with tablelayout/columnlayout inside tabs, do not: the desktop hungs with the "Processing" message.

If a refresh the safari window, the desktop is rebuilt and runs fine till i open the complex window.
But, it happends that refreshing the safari window and retrying i usually can make those complex windows to work again. And from here on the problem is gone.


So, it must be some bug on the render engine but i don't know how to reproduce it outside my application. As dastultz asked before, any ideas to solve this?

link publish delete flag offensive edit

answered 2009-04-23 03:00:08 +0800

jumperchen gravatar image jumperchen
3909 2 8
http://jumperchen.blogspo... ZK Team

Hi all,

Could you try the latest ZK version?

/Jumper

link publish delete flag offensive edit

answered 2009-04-23 13:16:50 +0800

dastultz gravatar image dastultz
797 8

Hi Jumper,

Would you be referring to 3.6.0 or the current Freshly? Is Freshly considered production-ready (stable)? Is Freshly a bug fix branch or the latest development?

Do you have reason to believe changes from 3.5.2 to 3.6.0 might affect this problem?

/Daryl

link publish delete flag offensive edit

answered 2009-04-24 01:52:23 +0800

jumperchen gravatar image jumperchen
3909 2 8
http://jumperchen.blogspo... ZK Team

Hi Dary,

I just recommend you to give it a try, because from our environment we cannot reproduce your issue.
Or is it possible to provide a sample, or an URL can access it to clarify the issue?

BTW, according to our policy, I strongly recommend to use ZK 3.6.x instead of ZK 3.5.x

/Jumper

link publish delete flag offensive edit

answered 2009-04-24 11:52:32 +0800

dastultz gravatar image dastultz
797 8

Yes, unfortunately, I can't reproduce it either - I'm relying on user feedback.

I'm testing 3.6.x now but I'm still looking for an explanation of the difference between the main release and Freshly. Should I be concerned about using Freshly in a production environment?

/Daryl

link publish delete flag offensive edit

answered 2009-04-24 11:54:46 +0800

dastultz gravatar image dastultz
797 8

Interestingly as I posted the previous comment, it hung on "Processing..." for quite some time. Maybe 40-50 seconds the Processing box showed for 5 seconds or so, disappeared and quickly reappeared. Finally the post was successful. Hmmm...

/Daryl

link publish delete flag offensive edit

answered 2009-04-27 02:25:26 +0800

jumperchen gravatar image jumperchen
3909 2 8
http://jumperchen.blogspo... ZK Team

Hi,

The ZK 3.6.1 will be released this week.
As you mentioned the hanging on "Processing", it could be a resending the HTTP-Request mechanism in our Enterprise version. Sometimes, the request in IE6 cannot successfully be sent to server.

/Jumper

link publish delete flag offensive edit

answered 2014-01-02 06:33:06 +0800

abb222222 gravatar image abb222222
30

infinite "Processing..." occurs in my app. I have a page with more than 10 Combobox. I reproduce by quickly selecting different option in different combobox.

I captured the request traffic by IE 9 development tool F12. The request shows as Pending. After 10 mins, the request shows Aborted.

zk5.0.7 and IE 9.0

link publish delete flag offensive edit
Your reply
Please start posting your answer anonymously - your answer will be saved within the current session and published after you log in or create a new account. Please try to give a substantial answer, for discussions, please use comments and please do remember to vote (after you log in)!

[hide preview]

Question tools

Follow

RSS

Stats

Asked: 2009-04-21 19:27:48 +0800

Seen: 328 times

Last updated: Jan 02 '14

Support Options
  • Email Support
  • Training
  • Consulting
  • Outsourcing
Learn More