0

No cache in ZK

asked 2009-02-24 14:28:16 +0800

issamlaabidi gravatar image issamlaabidi
217 2

hi, how can ZK prevent the browser from making the cashe of the pages .zul?
please help, thanks

delete flag offensive retag edit

3 Replies

Sort by ยป oldest newest

answered 2009-02-25 00:07:32 +0800

YamilBracho gravatar image YamilBracho
1722 2

You can use the page directive at the begining of your zul page, property cacheable
Check http://www.zkoss.org/doc/devref/ch02s02s07.html

link publish delete flag offensive edit

answered 2009-02-25 00:43:15 +0800

dennis gravatar image dennis
3669 1 6
http://www.javaworld.com....

I think default zul page sets to no cache already.

link publish delete flag offensive edit

answered 2018-06-26 11:07:12 +0800

matthung gravatar image matthung
3 2

Set org.zkoss.web.classWebResource.cache to false in zk.xml

<?xml version="1.0" encoding="UTF-8"?>
<zk>
    <library-property>
        <name>org.zkoss.web.classWebResource.cache</name>
        <value>false</value>
    </library-property>
</zk>
link publish delete flag offensive edit
Your reply
Please start posting your answer anonymously - your answer will be saved within the current session and published after you log in or create a new account. Please try to give a substantial answer, for discussions, please use comments and please do remember to vote (after you log in)!

[hide preview]

Question tools

Follow

RSS

Stats

Asked: 2009-02-24 14:28:16 +0800

Seen: 503 times

Last updated: Jun 26

Support Options
  • Email Support
  • Training
  • Consulting
  • Outsourcing
Learn More