0

Parse error in application web.xml

asked 2009-01-05 13:00:46 +0800

Ciccio gravatar image Ciccio
18 2 2 2

Hi all.
I write from Italy

I have following Installations tutorial http://zkoss.org/doc/installzk.dsp
When I browser http://localhost:8080/zkdemo
I receive this error from tomcat "HTTP Status 404 -"

In the log Catalina.out I have find this:
GRAVE: Parse error in application web.xml file at jndi:/localhost/zkdemo/WEB-INF/web.xml
org.xml.sax.SAXParseException: The markup in the document following the root element must be well-formed.
at com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser.parse(Unknown Source)
at com.sun.org.apache.xerces.internal.jaxp.SAXParserImpl$JAXPSAXParser.parse(Unknown Source)
at org.apache.tomcat.util.digester.Digester.parse(Digester.java:1562)
at org.apache.catalina.startup.ContextConfig.applicationWebConfig(ContextConfig.java:348)
at org.apache.catalina.startup.ContextConfig.start(ContextConfig.java:1048)
at org.apache.catalina.startup.ContextConfig.lifecycleEvent(ContextConfig.java:261)
at org.apache.catalina.util.LifecycleSupport.fireLifecycleEvent(LifecycleSupport.java:120)
at org.apache.catalina.core.StandardContext.start(StandardContext.java:4148)
at org.apache.catalina.core.ContainerBase.addChildInternal(ContainerBase.java:760)
at org.apache.catalina.core.ContainerBase.addChild(ContainerBase.java:740)
at org.apache.catalina.core.StandardHost.addChild(StandardHost.java:544)
at org.apache.catalina.startup.HostConfig.deployDirectory(HostConfig.java:927)
at org.apache.catalina.startup.HostConfig.deployDirectories(HostConfig.java:890)
at org.apache.catalina.startup.HostConfig.deployApps(HostConfig.java:492)
at org.apache.catalina.startup.HostConfig.start(HostConfig.java:1150)
at org.apache.catalina.startup.HostConfig.lifecycleEvent(HostConfig.java:311)
at org.apache.catalina.util.LifecycleSupport.fireLifecycleEvent(LifecycleSupport.java:120)
at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1022)
at org.apache.catalina.core.StandardHost.start(StandardHost.java:736)
at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1014)
at org.apache.catalina.core.StandardEngine.start(StandardEngine.java:443)
at org.apache.catalina.core.StandardService.start(StandardService.java:448)
at org.apache.catalina.core.StandardServer.start(StandardServer.java:700)
at org.apache.catalina.startup.Catalina.start(Catalina.java:552)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:616)
at org.apache.catalina.startup.Bootstrap.start(Bootstrap.java:295)
at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:433)

Somebody can help me?

My configurations is:
Os: linux fc9
Tomcat: apache-tomcat-5.5.27
Java:
JAVA_HOME=/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0
JRE_HOME=/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0/jre

Thanks in advanced

delete flag offensive retag edit

4 Replies

Sort by ยป oldest newest

answered 2009-01-05 13:12:28 +0800

Ciccio gravatar image Ciccio
18 2 2 2

This is the project structure:
+xsd
+src
index.zul
-WEB-INF
web.xml
+tld
-lib
|bsh.jar
|commons-collections.jar
|commons-fileupload.jar
|commons-io.jar
|commons-logging.jar
|fckez.jar
|Filters.jar
|gmapsz.jar
|groovy.jar
|itext.jar
|jasperreports.jar
|jcommon.jar
|jfreechart.jar
|jruby.jar
|js.jar
|jxl.jar
|jython.jar
|lib.txt
|mvel.jar
|ognl.jar
|poi.jar
|timelinez.jar
|timeplotz.jar
|zcommon.jar
|zcommons-el.jar
|zhtml.jar
|zkex.jar
|zkforge
|zk.jar
|zkmax.jar
|zkplus.jar
|zml.jar
|zul.jar
|zweb.jar

link publish delete flag offensive edit

answered 2009-01-05 13:44:38 +0800

mjablonski gravatar image mjablonski
1284 3 5
http://www.jease.org/

Hi,

please check your web.xml (as your stacktrace says), maybe a tag isn't closed properly or you've made a typo somewhere:

GRAVE: Parse error in application web.xml file at jndi:/localhost/zkdemo/WEB-INF/web.xml
org.xml.sax.SAXParseException: The markup in the document following the root element must be well-formed.

If you cannot find the bug, please post the web.xml.

Cheers, Maik

link publish delete flag offensive edit

answered 2009-01-05 13:49:08 +0800

mjablonski gravatar image mjablonski
1284 3 5
http://www.jease.org/

Maybe you've taken the example from the page mentioned above as it is... This won't work, you'll have to enclose the content in a proper root-tag called web-app. So please use the following as template (place the code in the middle).

HTH, Maik

<?xml version="1.0" encoding="UTF-8"?>

<web-app version="2.4" xmlns="http://java.sun.com/xml/ns/j2ee"
 xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
 xsi:schemaLocation="http://java.sun.com/xml/ns/j2ee http://java.sun.com/xml/ns/j2ee/web-app_2_4.xsd"> 

  ... Content of web.xml goes here...

</web-app>

link publish delete flag offensive edit

answered 2009-01-05 15:19:32 +0800

Ciccio gravatar image Ciccio
18 2 2 2

sometimes the haste, create problem where there are no problem...
I have resolve my problem with the tags of mjablonski ;)

thanks for help me...

link publish delete flag offensive edit
Your reply
Please start posting your answer anonymously - your answer will be saved within the current session and published after you log in or create a new account. Please try to give a substantial answer, for discussions, please use comments and please do remember to vote (after you log in)!

[hide preview]

Question tools

Follow

RSS

Stats

Asked: 2009-01-05 13:00:46 +0800

Seen: 6,231 times

Last updated: Jan 05 '09

Support Options
  • Email Support
  • Training
  • Consulting
  • Outsourcing
Learn More