0

ZK portlets and Oracle Portal 10.1.4.0

asked 2008-05-14 17:03:01 +0800

admin gravatar image admin
18691 1 10 129
ZK Team


Orignial message at:
https://sourceforge.net/forum/message.php?msg_id=4963194

By: maragakis

Hello,

i am trying to deploy a portlet at OC4J 10.1.3 an them display it on Oracle Portal 10.1.4.

When i am accessing the application as a standalone web app, it works just fine.
But when i add it as a portlet in Oracle Portal 10.1.4 using a WSRP Provider, it does not renders it at all.

Does anyone have a clue for that?

Thanks in advance



delete flag offensive retag edit

1 Reply

Sort by » oldest newest

answered 2011-11-03 11:39:13 +0800

v0v87 gravatar image v0v87
3

Hello! Have you solved your problem? I found that zkoss generate wrong URLs like:
http://<host>:<WebCenter Spaces port>/PortletProducerApp2-Portlets-context-root/zkau/web/dbd7a529/zk/img/progress4.gif
instead:
http://<host>:<WebCenter Spaces port>/webcenter/resourceproxy/~.portletId~3D~252Foracle~252Fadf~252Fportlet~252FscopedMD~252Fs8bba98ff_4cbb_40b8_beee_296c916a23ed~252Fportlets~252FPortlet1_095af2c6_d3ae_4fa4_8aac_10f515dd2a8a~26clientId~3D1532933860~26resourceId~3Dwsrp-url~25253Dhttp~2525253A~2525252F~2525252Fhs-c06-as01-udu.pds.otr.ru~2525253A8889~2525252FPortletProducerApp2-Portlets-context-root~2525252Fzkau~2525252Fweb~2525252Fdbd7a529~2525252Fzk~2525252Fimg~2525252Fprogress4.gif~252526wsrp-resourceID~25253D~252526wsrp-preferOperation~25253Dfalse~252526wsrp-requiresRewrite~25253Dtrue~252526wsrp-resourceState~25253D~252526wsrp-resourceCacheability~25253D~26baseUrl~3Dhttp~253A~252F~252Fhs-c06-as01-udu.pds.otr.ru~253A8888~252Fwebcenter~252Ffaces~252Foracle~252Fwebcenter~252Fpage~252FscopedMD~252Fs8bba98ff_4cbb_40b8_beee_296c916a23ed~252FbusinessRolePages~252FPage1.jspx~253F_adf.ctrl-state~253Dro4topobj_290~2526_afrLoop~253D97196325909000~26checksum~3D3ec44475a70d166fd9e39f6c10516e208a129370/progress4.gif
and resource files (e.g. JavaScript, CSS, Images) are not load.
I implemented my own URLEncoder which rewrite wrong URLs (http://books.zkoss.org/wiki/ZK_Developer%27s_Reference/Performance_Tips/Load_JavaScript_and_CSS_from_Server_Nearby). All the resources are loaded, but I have got new error in JavaScript zk.pwd (row 7813, debug-js enabled) “Failed to mount: ctx.lastIndexOf is not a function”. I think, that ZK cannot parse WSRP URLs. Could anybody help me please?

link publish delete flag offensive edit
Your reply
Please start posting your answer anonymously - your answer will be saved within the current session and published after you log in or create a new account. Please try to give a substantial answer, for discussions, please use comments and please do remember to vote (after you log in)!

[hide preview]

Question tools

Follow

RSS

Stats

Asked: 2008-05-14 17:03:01 +0800

Seen: 314 times

Last updated: Nov 03 '11

Support Options
  • Email Support
  • Training
  • Consulting
  • Outsourcing
Learn More