1

Bug in multiple command

asked 2019-04-08 12:56:46 +0800

superium gravatar image superium
29 4

when write:

<button label="search" onClick="@command('hideSearchWin','doSearch')" width="200px" />

i found the first command is not fired, only the second command was executed. i switch the two.also only the second command was executed.

i'm on zk 8.6.0.1

delete flag offensive retag edit

2 Answers

Sort by » oldest newest most voted
0
link publish delete flag offensive edit
0

answered 2019-04-08 15:27:40 +0800

superium gravatar image superium
29 4

i followed http://books.zkoss.org/zk-mvvm-book/8.0/syntax/viewmodelcommand.html and https://www.zkoss.org/wiki/ZK_Developer%27s_Reference/MVVM/Syntax/ViewModel (https://www.zkoss.org/wiki/ZKDeveloper%27sReference/MVVM/Syntax/ViewModel)/@Command

but got:

org.zkoss.util.IllegalSyntaxException: only allow one string of @command,but contains ['doSearch', 'hideSearchWin']

you're right,seems only one allowed currently.

link publish delete flag offensive edit

Comments

try :@command('hideSearchWin') @command('doSearch') maybe that works

chillworld ( 2019-04-08 16:00:12 +0800 )edit

Thanks for your kind,but this way also got : Allow only one command binding for event onClick of <Button s5EQd4>

superium ( 2019-04-11 15:36:59 +0800 )edit

then it's posting the second command in the first command.

chillworld ( 2019-04-11 15:54:22 +0800 )edit
Your answer
Please start posting your answer anonymously - your answer will be saved within the current session and published after you log in or create a new account. Please try to give a substantial answer, for discussions, please use comments and please do remember to vote (after you log in)!

[hide preview]

Question tools

Follow

RSS

Stats

Asked: 2019-04-08 12:56:46 +0800

Seen: 9 times

Last updated: Apr 08

Support Options
  • Email Support
  • Training
  • Consulting
  • Outsourcing
Learn More