0

ZK SpringBoot 'template' - cannot find template source [closed]

asked 2019-03-28 16:08:22 +0800

davout gravatar image davout
1435 3 18

updated 2019-03-28 16:12:36 +0800

I'm building my first ZK/Springboot web app using the new https://github.com/zkoss/zkspringboot

My index page is using templates but when I run the index.zul page I get an error

The index.zul page is defined as...

<zk>
<apply templateURI="/public/template_public.zul">
     <template name="header" src="/public/header_public.zul" />
     <template name="main" src="/public/main_index.zul" />
</apply>
</zk>

The index.zul page is located in folder: main/resources/web/zul The template files are located in folder: main/resources/web/zul/public

My application.properties file has... zk.homepage=index zk.zul-view-resolver-prefix=/zul

When I run the app and open the index page I get an error:
"Page not found: /public/template_public.zul"

Any suggestions?

delete flag offensive retag edit

The question has been closed for the following reason "duplicate question" by cor3000
close date 2019-04-03 09:42:21

1 Answer

Sort by » oldest newest most voted
0

answered 2019-04-03 09:42:08 +0800

cor3000 gravatar image cor3000
4466 2 7
ZK Team

answered here: https://github.com/zkoss/zkspringboot/issues/12

link publish delete flag offensive edit

Question tools

Follow

RSS

Stats

Asked: 2019-03-28 16:08:22 +0800

Seen: 4 times

Last updated: Apr 03

Support Options
  • Email Support
  • Training
  • Consulting
  • Outsourcing
Learn More