0

zk charts Disable Export Option [closed]

asked 2019-02-24 13:48:40 +0800

Senthilchettyin gravatar image Senthilchettyin flag of India
2615 3 8
http://emrpms.blogspot.in...

How to disable Export option and how to remove border here ?

image description

delete flag offensive retag edit

The question has been closed for the following reason "the question is answered, right answer was accepted" by Senthilchettyin
close date 2019-02-25 16:49:59

2 Answers

Sort by ยป oldest newest most voted
1

answered 2019-02-25 10:55:53 +0800

cor3000 gravatar image cor3000
4406 2 7
ZK Team

by default the chart doesn't render a border around the plot area. So the answer would be NOT to set a plotBorderColor/plotBorderWidth (or call the corresponding setters: setPlotBorderColor/Width).

<charts type="pie" model="${model}" height="400" width="600" />
<charts type="pie" model="${model}" height="400" width="600" plotBorderWidth="1" plotBorderColor="red" />

The exporting menu can be disabled by calling:

chart.getExporting().setEnabled(false);

Since both options seem quite obvious I would assume you already tried those. If there is/was a problem please also state your zkcharts version version and provide runnable code to show the problem.

link publish delete flag offensive edit
0

answered 2019-02-25 16:49:30 +0800

Senthilchettyin gravatar image Senthilchettyin flag of India
2615 3 8
http://emrpms.blogspot.in...

Thanks it works

link publish delete flag offensive edit

Question tools

Follow
1 follower

RSS

Stats

Asked: 2019-02-24 13:48:40 +0800

Seen: 8 times

Last updated: Feb 25

Support Options
  • Email Support
  • Training
  • Consulting
  • Outsourcing
Learn More