0

Cannot using Fragment after upgrade to ZK 8.5.2.1

asked 2018-11-06 17:14:03 +0800

Rijens gravatar image Rijens
1

Hello im new in developer ZK, im trying for upgrade ZK framework from existing (ZK 8.0.0.3) to zk 8.5.2.1, actually i have did it with change ZK version at the POM. xml. But when im trying for using fragment on my zul there is error. The error say "Could not initialize class org.zkoss.zkmax.zul.Fragment".

If you have any advice or solution for this please tell me it will mean a lot. Thank you

delete flag offensive retag edit

1 Reply

Sort by ยป oldest newest

answered 2018-11-08 15:05:35 +0800

cor3000 gravatar image cor3000
4263 1 7
ZK Team

hmm I tested our zkfragment-demo-part2 project

I updated the version to 8.5.2.1(-Eval) and it still works as expected without producing the error you encounter.

By looking into the pom.xml you can compare your setup to our demo. Maybe it helps to identify what's missing in your case, or what needs to be added to the demo to produce the error. (it could be that replacing the demo's pom file with your pom dependencies causes the problem already in the simple cases)

Also if you can provide a full error stack trace or your pom file it might help to pinpoint where the problem happens.

link publish delete flag offensive edit
Your reply
Please start posting your answer anonymously - your answer will be saved within the current session and published after you log in or create a new account. Please try to give a substantial answer, for discussions, please use comments and please do remember to vote (after you log in)!

[hide preview]

Question tools

Follow
1 follower

RSS

Stats

Asked: 2018-11-06 17:14:03 +0800

Seen: 3 times

Last updated: Nov 08

Support Options
  • Email Support
  • Training
  • Consulting
  • Outsourcing
Learn More