0

Popup with radiogroup not working? [closed]

asked 2018-08-24 19:21:41 +0800

tisaksen gravatar image tisaksen
44 5

updated 2018-08-24 19:26:47 +0800

I am trying to place a simple collection of radiobuttons inside a popup and it's not working. The radiobuttons can't be selected. Am I doing something wrong?

<window border="none">

    <popup id="mypop">
        <radiogroup>
            <radio value="A"/>
            <radio value="B"/>
            <radio value="C"/>
            <radio value="D"/>
            <radio value="E"/>
        </radiogroup>
    </popup>

    <button popup="mypop" label="Click to pop"/>
</window>
delete flag offensive retag edit

The question has been closed for the following reason "the question is answered, right answer was accepted" by cor3000
close date 2018-08-30 16:48:50

2 Answers

Sort by ยป oldest newest most voted
1

answered 2018-08-27 12:10:53 +0800

cor3000 gravatar image cor3000
4141 1 7
ZK Team

Hi,

your example seems to match the existing issue ZK-3866

I tested your example on zkfiddle an was able to reproduce it in version 8.5.0. According to the JIRA ticket this issue doesn't occur anymore when using 8.5.1 or above.

The ticket also mentions a workaround which I applied to your example which also restored the radio group behavior -> http://zkfiddle.org/sample/25gpl2o/1-workaround-ZK-3866

Robert

link publish delete flag offensive edit

Comments

Seems like a match yes. Thank you for the workaround :-)

tisaksen ( 2018-08-27 15:04:15 +0800 )edit

It actually doesn't work when I use selectdItem="@bind(....)" - same issue. I can't believe it.

tisaksen ( 2018-09-05 17:20:35 +0800 )edit

hmm I tested what you described ... it works for me ... I can't believe it :D http://zkfiddle.org/sample/25gpl2o/2-popup-bind-selectedItem

looks like you have a typo in 'selectdItem' should be 'selectedItem'

cor3000 ( 2018-09-05 17:44:38 +0800 )edit

Haha okay but in my actual code I don't have that typo. Something else must be causing the problem. I will see if I can create a reproducible example.

tisaksen ( 2018-09-05 18:06:31 +0800 )edit

I thought so as well, in case you find the source of the problem, can you please open a new question and simply link it here? then we'll continue there. or post it directly in our issue tracker (http://tracker.zkoss.org) and just leave a link in a comment

cor3000 ( 2018-09-05 18:34:45 +0800 )edit

Question tools

Follow
1 follower

RSS

Stats

Asked: 2018-08-24 19:21:41 +0800

Seen: 14 times

Last updated: Aug 30

Support Options
  • Email Support
  • Training
  • Consulting
  • Outsourcing
Learn More