0

SCRIPT: Permission denied in IE11 and Edge

asked 2018-06-07 22:38:46 +0800

mskala gravatar image mskala
1

Hello,

we ran into an issue, when we upgraded zk from 6.5 to 8.5.0. The issue is related to loading content into an iframe (a pdf viewer, which is using pdfjs library). It's throwing SCRIPT70 Permission denied errors to console and it stops running the javascript. Looking for a solution I found several articles about this issue and the issue is related to the jQuery library, version 1.10.2. Would it be possible to upgrade the jQuery version, to fix the IE11/Edge issue? Thank you, Michal

delete flag offensive retag edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2018-06-29 11:59:14 +0800

cor3000 gravatar image cor3000
4079 1 7
ZK Team

updated 2018-06-29 12:09:27 +0800

a ticket to upgrade the jquery version already exists... ZK-3719

Maybe the workaround in this ticket is related to your issue.

It is also possible to include your own version of jQuery next to ZK's internal version.

ZK aliases (and uses) the $() function as jq() allowing to implement custom client side features leveraging a different jquery version.

Here an example illustrating this: http://zkfiddle.org/sample/35cvnf2/1-custom-jquery-version

link publish delete flag offensive edit
Your answer
Please start posting your answer anonymously - your answer will be saved within the current session and published after you log in or create a new account. Please try to give a substantial answer, for discussions, please use comments and please do remember to vote (after you log in)!

[hide preview]

Question tools

Follow
1 follower

RSS

Stats

Asked: 2018-06-07 22:38:46 +0800

Seen: 7 times

Last updated: Jun 29

Support Options
  • Email Support
  • Training
  • Consulting
  • Outsourcing
Learn More