0

Property not found on type org.slf4j.impl.Log4jLoggerAdapter at

asked 2018-04-04 16:18:27 +0800

Radoslav86 gravatar image Radoslav86
13 3

I have a listbox whit object in zul, when i open this zul I have no problem. But when i open other zul whit gmap where i cat see some points and return to first one i have "Property not found on type org.slf4j.impl.Log4jLoggerAdapter". In VM i print property and everything is fine I have data, but zul can`t read property. This happens only when I open the zul where i see gmap first. Вoth zul have two different VM аnd there is no transfer of parameters between them.

delete flag offensive retag edit

2 Answers

Sort by » oldest newest most voted
0

answered 2018-04-10 15:23:17 +0800

cor3000 gravatar image cor3000
4143 1 7
ZK Team

a reproducing example would be most helpful, also the versions of java/ZK/slf4j/zkgmaps used in your case might contribute to finding a solution.

link publish delete flag offensive edit
0

answered 2018-04-18 14:17:03 +0800

Radoslav86 gravatar image Radoslav86
13 3

Problem was gmaps configuration have object whit name "log" and in my zul i use "var=log" . When map is open , and after this open my zul he dont use object from VM, he use gmap "log" object

link publish delete flag offensive edit
Your answer
Please start posting your answer anonymously - your answer will be saved within the current session and published after you log in or create a new account. Please try to give a substantial answer, for discussions, please use comments and please do remember to vote (after you log in)!

[hide preview]

Question tools

Follow
2 followers

RSS

Stats

Asked: 2018-04-04 16:18:27 +0800

Seen: 6 times

Last updated: Apr 18

Support Options
  • Email Support
  • Training
  • Consulting
  • Outsourcing
Learn More