0

zk.googleAPIkey not work with "YOUR_CLIENT_ID"? [closed]

asked 2018-02-09 01:34:42 +0800

JorgeBp gravatar image JorgeBp
1

Hello guys. I´m new on ZK and I´m trying to get a gmaps with client autentication, but, in ZK portal just can see a api key example, does anny one can tell me how can I do a client auntentication example? .

Thank you very much.

delete flag offensive retag edit

The question has been closed for the following reason "the question is answered, right answer was accepted" by cor3000
close date 2018-02-12 09:27:22

Comments

Hello cor3000 I delete: <script type="text/javascript" content="zk.googleAPIkey='XIzaSyDtCk'"/>

replace adding "client" attribute like:

<gmaps client="googleautorizedclient_id"... and, it works perfectly,

Tank's my friend!

JorgeBp ( 2018-02-10 01:22:31 +0800 )edit

you're welcome!

cor3000 ( 2018-02-12 09:27:06 +0800 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2018-02-09 11:42:36 +0800

cor3000 gravatar image cor3000
3907 1 7
ZK Team

you have to set the clientId in the client-attribute: e.g.:

<gmaps width="200px" height="200px" client="YOUR_CLIENT_ID"/>

See https://github.com/zkoss/zkgmapsz/blob/3.0.4/gmapsz/src/org/zkoss/gmaps/Gmaps.java#L135

link publish delete flag offensive edit

Question tools

Follow
3 followers

RSS

Stats

Asked: 2018-02-09 01:34:42 +0800

Seen: 10 times

Last updated: Feb 09