0

Datebox format bug for format="MMMyy" and locale="en_EN"

asked 2018-02-06 18:10:50 +0800

napule77 gravatar image napule77
15 3

updated 2018-02-06 18:13:03 +0800

Hi I think there is a bug in versione 8.5.0 :

<datebox id="megaDate"   format="MMMyy"  locale="en_EN" readonly="true" ></datebox>

Settin for example Feb 6 2018 I can see FEB18 but if i change year for example May 2010 I see alway MAY18. If I use format ="MMM-yyyy" all works! So I use format="MMMyyyy" same problem!

It's a bug?

delete flag offensive retag edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2018-02-09 10:34:15 +0800

cor3000 gravatar image cor3000
3690 1 7
ZK Team

Hi,

Thanks for posting this problem. It definitely looks like a client side issue. While it's possible to set and format an initial date from the server side correctly, the client side fails to update the year when certain date patterns are applied.

I was able to reproduce the problem with other similar format patterns in a zkfiddle.

I posted the issue ZK-3868 in our tracker to get this addressed in a future version.

Robert

link publish delete flag offensive edit
Your answer
Please start posting your answer anonymously - your answer will be saved within the current session and published after you log in or create a new account. Please try to give a substantial answer, for discussions, please use comments and please do remember to vote (after you log in)!

[hide preview]

Question tools

Follow
2 followers

RSS

Stats

Asked: 2018-02-06 18:10:50 +0800

Seen: 10 times

Last updated: Feb 09