0

How to update ZK version in Eclipse?

asked 2017-01-19 03:30:11 +0800

bayuprams gravatar image bayuprams
1

I am currently using zk 6.5 CE.

What is the right was to update a project to zk EE 8.0.4 in a (NON-MAVEN) project?

cause i still got problem when try to call navbar.class, this error "Component definition not found: navbar in [LanguageDefinition: xul/html]"

thanks

delete flag offensive retag edit

7 Replies

Sort by ยป oldest newest

answered 2017-01-19 08:14:22 +0800

Darksu gravatar image Darksu
1991 1 4

Hello bayuprams,

You have to update your workspace by:

  1. Download latest version
  2. In Eclipse Open Window->Preferences->ZK->ZK Packages
  3. Click Add File/Directory
  4. Open archived file

And then for your project do:

  1. Right Click on Project and enter Properties
  2. Goto ZK->Package Settings
  3. Select the ZK Package
  4. And Re-Associate Source Jar Files

Do not forget to clean up your application server and restart.

Best Regards,

Darksu

link publish delete flag offensive edit

answered 2017-01-24 15:32:02 +0800

bayuprams gravatar image bayuprams
1

after step Right Click on Project and enter Properties, then goto ZK, i'm not found menu package settings, zk package untill re-associate source jar files. Why? my eclipse version is neon 2(4.6.2).

thanks.

link publish delete flag offensive edit

answered 2017-01-24 15:42:37 +0800

Rendika gravatar image Rendika
1

updated 2017-01-24 16:27:35 +0800

I have same problem right here... Hi Mr.Darksu I was following your step and I have some problem, I cant find package setting at

.2. Goto ZK->Package Settings

am I skip a few steps? and one more, how i know that zk its been updated? where I cant see that..

Thanks

link publish delete flag offensive edit

answered 2017-01-25 09:25:50 +0800

Darksu gravatar image Darksu
1991 1 4

Hello,

Did you install zk studio?

https://www.zkoss.org/wiki/ZKStudioEssentials/Installation

Best Regards,

Darksu

link publish delete flag offensive edit

answered 2017-01-25 14:51:41 +0800

Rendika gravatar image Rendika
1

I've been up here so surely I've installed studio zk

And then for your project do:

1 Right Click on Project and enter Properties
2 Goto ZK->Package Settings --------------------<<
3 Select the ZK Package
4 And Re-Associate Source Jar Files

I'm not see that package setting right there...

link publish delete flag offensive edit

answered 2017-01-26 08:34:17 +0800

Darksu gravatar image Darksu
1991 1 4

Hello Rendika,

That is weird. What version of Eclipse IDE are you using? I am currenty using eclipse-jee-oxygen-M4-win32-x86_64

Best Regards,

Darksu

link publish delete flag offensive edit

answered 2017-01-26 09:19:08 +0800

Rendika gravatar image Rendika
1

I currently using eclipse-jee-neon-2-win32-x86_64...

link publish delete flag offensive edit
Your reply
Please start posting your answer anonymously - your answer will be saved within the current session and published after you log in or create a new account. Please try to give a substantial answer, for discussions, please use comments and please do remember to vote (after you log in)!

[hide preview]

Question tools

Follow
1 follower

RSS

Stats

Asked: 2017-01-19 03:30:11 +0800

Seen: 74 times

Last updated: Jan 26 '17

Support Options
  • Email Support
  • Training
  • Consulting
  • Outsourcing
Learn More