0

java.lang.NullPointerException to update to zk 8.0.1

asked 2016-11-02 12:34:27 +0800

jvr17635 gravatar image jvr17635
1

Hello, I have a NullPointerException in JBoss server when I try to update zk 7.0.1 to 8.0.1 to my web project. Then I try to load my web pages and i get the next error:

JBWEB000309: type JBWEB000066: Exception report

JBWEB000068: message

JBWEB000069: description JBWEB000145: The server encountered an internal error that prevented it from fulfilling this request.

JBWEB000070: exception

java.lang.NullPointerException org.zkoss.zk.ui.metainfo.Parser.parseItem(Parser.java:1037) org.zkoss.zk.ui.metainfo.Parser.parse(Parser.java:244) org.zkoss.zk.ui.metainfo.Parser.parse(Parser.java:119) org.zkoss.zk.ui.metainfo.PageDefinitions$MyLoader.parse(PageDefinitions.java:215) org.zkoss.zk.ui.metainfo.PageDefinitions$MyLoader.parse(PageDefinitions.java:201) org.zkoss.web.util.resource.ResourceLoader.load(ResourceLoader.java:88) org.zkoss.web.util.resource.ResourceLoader.load(ResourceLoader.java:33) org.zkoss.util.resource.ResourceCache$Info.load(ResourceCache.java:227) org.zkoss.util.resource.ResourceCache$Info.<init>(ResourceCache.java:202) org.zkoss.util.resource.ResourceCache.get(ResourceCache.java:134) org.zkoss.web.util.resource.ResourceCaches.get(ResourceCaches.java:121) org.zkoss.zk.ui.metainfo.PageDefinitions.getPageDefinition(PageDefinitions.java:143) org.zkoss.zk.ui.impl.AbstractUiFactory.getPageDefinition(AbstractUiFactory.java:195) org.zkoss.zk.ui.http.DHtmlLayoutServlet.process(DHtmlLayoutServlet.java:210) org.zkoss.zk.ui.http.DHtmlLayoutServlet.doGet(DHtmlLayoutServlet.java:136) javax.servlet.http.HttpServlet.service(HttpServlet.java:734) javax.servlet.http.HttpServlet.service(HttpServlet.java:847)

Do you know why it is happening this?

delete flag offensive retag edit

Comments

When you update your zk version in your web project, should you change the web.xml in WEB-INF?

jvr17635 ( 2016-11-02 13:33:05 +0800 )edit

3 Answers

Sort by ยป oldest newest most voted
0

answered 2016-11-06 08:52:13 +0800

Darksu gravatar image Darksu
1991 1 4

Hello vr17635,

You should Clean working Directory and restart the server.

Also keep in mind to remove any old libraries from the lib directory.

Best Regards,

Darksu

link publish delete flag offensive edit
0

answered 2016-11-08 11:08:16 +0800

jvr17635 gravatar image jvr17635
1

Thanks Daksu very much for your answer!

But, what working directory do I have to clean? I use Maven, Do I have to do Maven clean in IDE Eclipse?

link publish delete flag offensive edit
0

answered 2016-11-08 11:54:11 +0800

Darksu gravatar image Darksu
1991 1 4

Hello vr17635,

You should clean using maven, and also clean your application server working directory.

Best Regards,

Darksu

link publish delete flag offensive edit
Your answer
Please start posting your answer anonymously - your answer will be saved within the current session and published after you log in or create a new account. Please try to give a substantial answer, for discussions, please use comments and please do remember to vote (after you log in)!

[hide preview]

Question tools

Follow
1 follower

RSS

Stats

Asked: 2016-11-02 12:34:27 +0800

Seen: 47 times

Last updated: Nov 08 '16

Support Options
  • Email Support
  • Training
  • Consulting
  • Outsourcing
Learn More