0

class not found

asked 2016-07-12 05:43:18 +0800

sanco gravatar image sanco
1

updated 2016-07-12 05:44:17 +0800

Hello. I got this error when build my zk app. cannot access XulElement. class not found org.zkoss.zul.impl.api.XulElemnt. There is no api package under zk libraries. I tried 6.5.3, 7.0.0, 7.0.3, 8.0.0.1 but all of them gives the same error. Can anyone help me to solve this problem.

delete flag offensive retag edit

Comments

I have only CE components. It works a few weeks ago but now does not work.

sanco ( 2016-07-12 07:37:58 +0800 )edit

Finally i found the reason. Just downgrade the lib version from 3.6.3 to 3.5.0 and everything is ok now

sanco ( 2016-07-12 12:52:41 +0800 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2016-07-12 07:11:39 +0800

Darksu gravatar image Darksu
1991 1 4

Hello sanco,

Probably you are getting the error because the component is available for the PE and EE of ZK.

Best Regards,

Darksu

link publish delete flag offensive edit
Your answer
Please start posting your answer anonymously - your answer will be saved within the current session and published after you log in or create a new account. Please try to give a substantial answer, for discussions, please use comments and please do remember to vote (after you log in)!

[hide preview]

Question tools

Follow
2 followers

RSS

Stats

Asked: 2016-07-12 05:43:18 +0800

Seen: 16 times

Last updated: Jul 12 '16

Support Options
  • Email Support
  • Training
  • Consulting
  • Outsourcing
Learn More