1

java.lang.AbstractMethodError: org.zkoss.zkmax.bind.impl.TrackerNodeImplEx.getDependents(Ljava/lang/Object;)Ljava/util/Set;

asked 2016-05-03 06:56:50 +0800

dmmax gravatar image dmmax
13 3

updated 2016-05-03 07:23:38 +0800

chillworld gravatar image chillworld flag of Belgium
5322 4 9
https://github.com/chillw...

I can't respond on my question (ht#tp://forum.zkoss.org/question/100778/not-send-parameters-via-command-from-native-table-mvvm/)

I have problem with zk library (zk-bind). I'm using 8 version.

pom.file:

<dependency>
        <groupId>org.zkoss.zk</groupId>
        <artifactId>zkbind</artifactId>
        <version>${zk.version}</version>
    </dependency>
    <dependency>
        <groupId>org.zkoss.zk</groupId>
        <artifactId>zul</artifactId>
        <version>${zk.version}</version>
    </dependency>
    <dependency>
        <groupId>org.zkoss.zk</groupId>
        <artifactId>zkplus</artifactId>
        <version>${zk.version}</version>
    </dependency>
    <dependency>
        <groupId>org.zkoss.zk</groupId>
        <artifactId>zhtml</artifactId>
        <version>${zk.version}</version>
    </dependency>

With these dependencies I have exception on refresh page (code: ht#tp://forum.zkoss.org/question/100778/not-send-parameters-via-command-from-native-table-mvvm/):

java.lang.AbstractMethodError: org.zkoss.zkmax.bind.impl.TrackerNodeImplEx.getDependents(Ljava/lang/Object;)Ljava/util/Set;
    at org.zkoss.bind.tracker.impl.TrackerImpl.tieValue(TrackerImpl.java:320)
    at org.zkoss.bind.xel.zel.BindELResolver.tieValue(BindELResolver.java:274)

When I delete dependencies above and add new:

pom.xml:

<dependency>
   <groupId>org.zkoss.common</groupId>
   <artifactId>zweb</artifactId>
   <version>${zk.version}</version>
</dependency>

Work fine, but there are new error:

May 03, 2016 1:41:17 PM org.zkoss.xel.taglib.Taglibs getDefaultTLDs SEVERE: org.zkoss.util.IllegalSyntaxException: <config-name> требуется ([null:jar:file:/home/dmmax/.m2/repository/org/zkoss/zk/zk/7.0.0/zk-7.0.0.jar!/metainfo/tld/config.xml:14:9]). at org.zkoss.idom.util.IDOMs.getRequiredElementValue(IDOMs.java:79) at org.zkoss.util.resource.ClassLocator$XMLResource.<init>(ClassLocator.java:141)

delete flag offensive retag edit

Comments

I'm using ZK CE. I can't use zkmax and zuti

dmmax ( 2016-05-03 08:21:22 +0800 )edit

I connected these parameters and dependencies. And still is showing errors

dmmax ( 2016-05-03 09:54:30 +0800 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2016-05-03 07:24:31 +0800

chillworld gravatar image chillworld flag of Belgium
5322 4 9
https://github.com/chillw...

updated 2016-05-03 12:40:42 +0800

You have transient dependencies of zk 7, this is because you add the org.zkoss.addons. Change the pom to :

<dependency>
        <groupId>org.zkoss.addons</groupId>
        <artifactId>zk-bootstrap</artifactId>
        <version>1.0.0</version>
           <exclusions>
            <exclusion>
                <groupId>org.zkoss.zk</groupId>
                <artifactId>zkex</artifactId>
            </exclusion>
            <exclusion>
                <groupId>org.zkoss.zk</groupId>
                <artifactId>zkmax</artifactId>
            </exclusion>
        </exclusions>
    </dependency>
link publish delete flag offensive edit
Your answer
Please start posting your answer anonymously - your answer will be saved within the current session and published after you log in or create a new account. Please try to give a substantial answer, for discussions, please use comments and please do remember to vote (after you log in)!

[hide preview]

Question tools

Follow
2 followers

RSS

Stats

Asked: 2016-05-03 06:56:50 +0800

Seen: 33 times

Last updated: May 03 '16

Support Options
  • Email Support
  • Training
  • Consulting
  • Outsourcing
Learn More