0

Problem with textbox value using mvvm and firefox

asked 2016-02-02 16:58:59 +0800

afxgroup gravatar image afxgroup
126 1

Hello, there is a problem with textbox value binded to a vm string with latest firefox (it works on chrome). Basically i've binded the textbox in this way (the usual way..):

<textbox type="text" id="j_username" name="j_username" sclass="form-control form-control-solid placeholder-no-fix fldUsername" placeholder="${c:l('login.username')}" value="@bind(vm.username)" constraint="no empty"/>

And i have a command that call the login function:

<button id="btnLogin" sclass="btn btn-success uppercase" onclick="@command('login')" label="${c:l('login.ok')}"/>

On chrome i have no problem even if i use the textbox as parameter in the login command using j_username.value and a BindingParameter. It is populated. While on Firefox is always empty. Not only with the two way binding the setter on the VM is never fired.

Anyone? I'm using zk8.1

delete flag offensive retag edit

Comments

Same issue when you set instant to true?

chillworld ( 2016-02-02 17:25:10 +0800 )edit

The problem was in a javascript function in the page that was causing this strange issue on firefox..

afxgroup ( 2016-02-02 17:45:03 +0800 )edit
Be the first one to answer this question!
Please start posting your answer anonymously - your answer will be saved within the current session and published after you log in or create a new account. Please try to give a substantial answer, for discussions, please use comments and please do remember to vote (after you log in)!

[hide preview]

Question tools

Follow
1 follower

RSS

Stats

Asked: 2016-02-02 16:58:59 +0800

Seen: 15 times

Last updated: Feb 02 '16

Support Options
  • Email Support
  • Training
  • Consulting
  • Outsourcing
Learn More