Revision history [back]

click to hide/show revision 1
initial version

answered 2017-09-27 10:49:17 +0800

cor3000 gravatar image cor3000

ZK Team

I could reproduce a bug when nesting the gmaps component inside an <hlayout>

so if you can live without that the easiest way is to just use a <div>

<div vflex="1" hflex="1">
    <gmaps width="100%" height="100%" version="3.26" id="gmaps" lat="37.4410" lng="-122.1490" showSmallCtrl="true" />
</div>

or

<div vflex="1" hflex="1">
    <gmaps vflex="1" hflex="1" version="3.26" id="gmaps" lat="37.4410" lng="-122.1490" showSmallCtrl="true" />
</div>

I could reproduce a bug when nesting the gmaps <gmaps> component inside an <hlayout>

so if image description

If you can live without that the easiest way is to just use a <div>

<div vflex="1" hflex="1">
    <gmaps width="100%" height="100%" version="3.26" id="gmaps" lat="37.4410" lng="-122.1490" showSmallCtrl="true" />
</div>

or

<div vflex="1" hflex="1">
    <gmaps vflex="1" hflex="1" version="3.26" id="gmaps" lat="37.4410" lng="-122.1490" showSmallCtrl="true" />
</div>

I could reproduce a bug when nesting the <gmaps> component inside an <hlayout>

image description

If you can live without that the easiest way is to just use a <div>

<div vflex="1" hflex="1">
    <gmaps width="100%" height="100%" version="3.26" id="gmaps" lat="37.4410" lng="-122.1490" showSmallCtrl="true" />
</div>

or

<div vflex="1" hflex="1">
    <gmaps vflex="1" hflex="1" version="3.26" id="gmaps" lat="37.4410" lng="-122.1490" showSmallCtrl="true" />
</div>

UPDATE: I posted the following bug ZKGMAPS-18

A simple workaround is to apply a min-width to the gmaps component:

<gmaps vflex="1" hflex="1" ... style="min-width: 1px" />
Support Options
  • Email Support
  • Training
  • Consulting
  • Outsourcing
Learn More